Section: extra-libs

Depends: alsa-lib, bluez, dbus, desktop-file-utils, fontconfig, geoclue, gst-plugins-base-1-0, hicolor-icon-theme, hyphen, icu, libinput, libjpeg-turbo, libmng, libproxy, libwebp, libxkbcommon, libxslt, mesa, openal-soft, pcre2, protobuf, pulseaudio, re2, snappy, sqlite, srtp, systemd, tslib, xcb-util-cursor, xcb-util-image, xcb-util-keysyms, xcb-util-renderutil, xcb-util-wm, xdg-utils

Depends (build): cmake, gperf, mariadb, ninja, postgresql, qt-5, ruby, sqlite, unixodbc

Replaces: qt-5-doc<=1:5.12.2+wk5.212.0, qtchooser<=1:64, qtvirtualkeyboard<=5.11.2

Breaks: qt-5-doc<=1:5.12.2+wk5.212.0, qtchooser<=1:64, qtvirtualkeyboard<=5.11.2

Links: Changelog, Reverse dependency, Report issues

Issue 401

BUILDDEP unmet

1:5.13.1+wk5.212.0-3 (aosc-os-abbs/stable)

Also: 1:5.13.1+wk5.212.0-3 (aosc-os-abbs/testing) , 1:5.13.1+wk5.212.0-3 (aosc-os-abbs/testing-proposed) , 1:5.13.1+wk5.212.0-2 (aosc-os-abbs/explosive) , 1:5.13.1+wk5.212.0-2 (aosc-os-abbs/stable-proposed)

Missing build dependencies:

  • cmake

Issue 421

File collision(s)

1:5.12.2+wk5.212.0-1 (armel/stable)

Also: 1:5.12.2+wk5.212.0 (powerpc/stable) , 1:5.12.2+wk5.212.0 (ppc64/stable)

Conflicts: qtspeech

qtspeech 5.10.1 (armel/stable)

  • /usr/include/qt5/QtTextToSpeech/QTextToSpeech
  • /usr/include/qt5/QtTextToSpeech/QTextToSpeechEngine
  • /usr/include/qt5/QtTextToSpeech/qtexttospeechengine.h
  • /usr/include/qt5/QtTextToSpeech/qtexttospeech_global.h
  • /usr/include/qt5/QtTextToSpeech/qtexttospeech.h
  • /usr/include/qt5/QtTextToSpeech/QTextToSpeechPlugin
  • /usr/include/qt5/QtTextToSpeech/qtexttospeechplugin.h
  • /usr/include/qt5/QtTextToSpeech/QtTextToSpeech
  • /usr/include/qt5/QtTextToSpeech/QtTextToSpeechDepends
  • /usr/include/qt5/QtTextToSpeech/QtTextToSpeechVersion
  • /usr/include/qt5/QtTextToSpeech/qttexttospeechversion.h
  • /usr/include/qt5/QtTextToSpeech/QVoice
  • /usr/include/qt5/QtTextToSpeech/qvoice.h
  • /usr/lib/cmake/Qt5TextToSpeech/Qt5TextToSpeechConfig.cmake
  • /usr/lib/cmake/Qt5TextToSpeech/Qt5TextToSpeechConfigVersion.cmake
  • /usr/lib/libQt5TextToSpeech.prl
  • /usr/lib/pkgconfig/Qt5TextToSpeech.pc
  • /usr/lib/qt5/mkspecs/modules/qt_lib_texttospeech.pri
  • /usr/lib/qt5/mkspecs/modules/qt_lib_texttospeech_private.pri
  • /usr/share/doc/qt5/examples/speech/hello_speak/hello_speak
  • /usr/share/doc/qt5/examples/speech/hello_speak/hello_speak.pro
  • /usr/share/doc/qt5/examples/speech/hello_speak/main.cpp
  • /usr/share/doc/qt5/examples/speech/hello_speak/mainwindow.cpp
  • /usr/share/doc/qt5/examples/speech/hello_speak/mainwindow.h
  • /usr/share/doc/qt5/examples/speech/hello_speak/mainwindow.ui
  • /usr/share/doc/qt5/examples/speech/speech.pro

Issue 432

Library dependency without PKGDEP

1:5.12.2+wk5.212.0-1 (armel/stable)

Depends: cups, freetype, gstreamer-1-0, gtk-3, harfbuzz, hunspell, jasper, lcms2, libdrm, libglvnd, libtiff, llvm, mariadb, mtdev, nspr, nss, opus, pango, postgresql, sdl2, unixodbc, wayland

llvm 7.0.1-4 (armel/stable)

  • libclang.so.7

cups 2.2.10-3 (armel/stable)

  • libcups.so.2

libdrm 2.4.99 (armel/stable)

  • libdrm.so.2

libglvnd 1.1.0 (armel/stable)

  • libEGL.so.1

freetype 2.9 (armel/stable)

  • libfreetype.so.6

gtk-3 3.24.4 (armel/stable)

  • libgdk-3.so.0

libglvnd 1.1.0 (armel/stable)

  • libGL.so.1

gstreamer-1-0 1.14.3-2 (armel/stable)

  • libgstbase-1.0.so.0
  • libgstreamer-1.0.so.0

gtk-3 3.24.4 (armel/stable)

  • libgtk-3.so.0

harfbuzz 2.3.1-1 (armel/stable)

  • libharfbuzz.so.0

hunspell 1.7.0-1 (armel/stable)

  • libhunspell-1.7.so.0

jasper 2.0.14-1 (armel/stable)

  • libjasper.so.4

lcms2 2.9-1 (armel/stable)

  • liblcms2.so.2

mariadb 10.3.13-2 (armel/stable)

  • libmariadb.so.3

mtdev 1.1.5-1 (armel/stable)

  • libmtdev.so.1

nspr 4.19 (armel/stable)

  • libnspr4.so

nss 3.36.7-1 (armel/stable)

  • libnss3.so
  • libnssutil3.so

unixodbc 2.3.7 (armel/stable)

  • libodbc.so.2

opus 1.2.1 (armel/stable)

  • libopus.so.0

pango 1.42.4-1 (armel/stable)

  • libpango-1.0.so.0

postgresql 11.4 (armel/stable)

  • libpq.so.5

sdl2 2.0.9 (armel/stable)

  • libSDL2-2.0.so.0

libtiff 4.0.10-3 (armel/stable)

  • libtiff.so.5

wayland 1.16.0-2 (armel/stable)

  • libwayland-client.so.0
  • libwayland-cursor.so.0
  • libwayland-egl.so.1
  • libwayland-server.so.0

1:5.12.2+wk5.212.0 (powerpc/stable)

Depends: cups, freetds, freetype, gst-plugins-bad-1-0, gstreamer-1-0, gtk-3, harfbuzz, hunspell, jasper, libdrm, libglvnd, libtiff, llvm, mtdev, pango, postgresql, unixodbc, wayland

llvm 7.0.1-4 (powerpc/stable)

  • libclang.so.7

cups 2.2.10-3 (powerpc/stable)

  • libcups.so.2

libdrm 2.4.97 (powerpc/stable)

  • libdrm.so.2

libglvnd 1.1.0 (powerpc/stable)

  • libEGL.so.1

freetype 2.9 (powerpc/stable)

  • libfreetype.so.6

gtk-3 3.24.4 (powerpc/stable)

  • libgdk-3.so.0

libglvnd 1.1.0 (powerpc/stable)

  • libGL.so.1

gstreamer-1-0 1.14.3-2 (powerpc/stable)

  • libgstbase-1.0.so.0

gst-plugins-bad-1-0 1.14.3-5 (powerpc/stable)

  • libgstphotography-1.0.so.0

gstreamer-1-0 1.14.3-2 (powerpc/stable)

  • libgstreamer-1.0.so.0

gtk-3 3.24.4 (powerpc/stable)

  • libgtk-3.so.0

harfbuzz 2.3.1-1 (powerpc/stable)

  • libharfbuzz.so.0

hunspell 1.7.0-1 (powerpc/stable)

  • libhunspell-1.7.so.0

jasper 2.0.14-1 (powerpc/stable)

  • libjasper.so.4

mtdev 1.1.5-1 (powerpc/stable)

  • libmtdev.so.1

unixodbc 2.3.7 (powerpc/stable)

  • libodbc.so.2

pango 1.42.4-1 (powerpc/stable)

  • libpango-1.0.so.0

postgresql 11.4 (powerpc/stable)

  • libpq.so.5

freetds 1.00.111-1 (powerpc/stable)

  • libsybdb.so.5

libtiff 4.0.10-3 (powerpc/stable)

  • libtiff.so.5

wayland 1.16.0-2 (powerpc/stable)

  • libwayland-client.so.0
  • libwayland-cursor.so.0
  • libwayland-egl.so.1
  • libwayland-server.so.0

1:5.12.2+wk5.212.0 (ppc64/stable)

Depends: cups, freetds, freetype, gst-plugins-bad-1-0, gstreamer-1-0, gtk-3, harfbuzz, hunspell, jasper, libdrm, libglvnd, libtiff, llvm, mariadb, mtdev, pango, postgresql, unixodbc, wayland

llvm 7.0.1-4 (ppc64/stable)

  • libclang.so.7

cups 2.2.10-3 (ppc64/stable)

  • libcups.so.2

libdrm 2.4.99 (ppc64/stable)

  • libdrm.so.2

libglvnd 1.1.0 (ppc64/stable)

  • libEGL.so.1

freetype 2.9 (ppc64/stable)

  • libfreetype.so.6

gtk-3 3.24.4 (ppc64/stable)

  • libgdk-3.so.0

libglvnd 1.1.0 (ppc64/stable)

  • libGL.so.1

gstreamer-1-0 1.14.3-2 (ppc64/stable)

  • libgstbase-1.0.so.0

gst-plugins-bad-1-0 1.14.3-5 (ppc64/stable)

  • libgstphotography-1.0.so.0

gstreamer-1-0 1.14.3-2 (ppc64/stable)

  • libgstreamer-1.0.so.0

gtk-3 3.24.4 (ppc64/stable)

  • libgtk-3.so.0

harfbuzz 2.3.1-1 (ppc64/stable)

  • libharfbuzz.so.0

hunspell 1.7.0-1 (ppc64/stable)

  • libhunspell-1.7.so.0

jasper 2.0.14-1 (ppc64/stable)

  • libjasper.so.4

mariadb 10.3.13-2 (ppc64/stable)

  • libmariadb.so.3

mtdev 1.1.5-1 (ppc64/stable)

  • libmtdev.so.1

unixodbc 2.3.7 (ppc64/stable)

  • libodbc.so.2

pango 1.42.4-1 (ppc64/stable)

  • libpango-1.0.so.0

postgresql 11.4 (ppc64/stable)

  • libpq.so.5

freetds 1.00.111-1 (ppc64/stable)

  • libsybdb.so.5

libtiff 4.0.10-3 (ppc64/stable)

  • libtiff.so.5

wayland 1.16.0-2 (ppc64/stable)

  • libwayland-client.so.0
  • libwayland-cursor.so.0
  • libwayland-egl.so.1
  • libwayland-server.so.0