Section: extra-java

Depends: ffmpeg, gst-plugins-base-1-0, gtk-2, openjdk, qt-5, webkit2gtk

Depends (build): cmake, gperf, ruby, unzip

Links: Changelog, Report issues

Issue 431

Library version (sover) dependency unmet

17+16 (amd64/openjdk17-experiment)

Also: 11.0.12+4 (amd64/stable)

Rebuild caused by: openjdk

(Dependency not found)

  • ld-linux-x86-64.2
  • libasound.2
  • libatk-1.0.0
  • libavcodec.58
  • libavformat.58
  • libc.6
  • libcairo.2
  • libcairo-gobject.2
  • libdl.2
  • libfontconfig.1
  • libfreetype.6
  • libgdk-3.0
  • libgdk_pixbuf-2.0.0
  • libgdk-x11-2.0.0
  • libgio-2.0.0
  • libGL.1
  • libglib-2.0.0
  • libgmodule-2.0.0
  • libgobject-2.0.0
  • libgstreamer-lite
  • libgthread-2.0.0
  • libgtk-3.0
  • libgtk-x11-2.0.0

openjdk 3:11.0.12+ga (amd64/stable)

  • libharfbuzz.0

(Dependency not found)

  • libm.6
  • libpango-1.0.0
  • libpangocairo-1.0.0
  • libpangoft2-1.0.0
  • libpthread.0
  • librt.1
  • libX11.6
  • libXtst.6
  • libXxf86vm.1

11.0.12+4 (arm64/stable)

Rebuild caused by: openjdk

(Dependency not found)

  • ld-linux-aarch64.1
  • libasound.2
  • libatk-1.0.0
  • libavcodec.58
  • libavformat.58
  • libc.6
  • libcairo.2
  • libcairo-gobject.2
  • libdl.2
  • libfontconfig.1
  • libfreetype.6
  • libgdk-3.0
  • libgdk_pixbuf-2.0.0
  • libgdk-x11-2.0.0
  • libgio-2.0.0
  • libGL.1
  • libglib-2.0.0
  • libgmodule-2.0.0
  • libgobject-2.0.0
  • libgstreamer-lite
  • libgthread-2.0.0
  • libgtk-3.0
  • libgtk-x11-2.0.0

openjdk 3:11.0.12+ga (arm64/stable)

  • libharfbuzz.0

(Dependency not found)

  • libm.6
  • libpango-1.0.0
  • libpangocairo-1.0.0
  • libpangoft2-1.0.0
  • libpthread.0
  • libX11.6
  • libXtst.6
  • libXxf86vm.1

11.0.12+4 (ppc64el/stable)

Rebuild caused by: openjdk

(Dependency not found)

  • ld64.2
  • libasound.2
  • libatk-1.0.0
  • libavcodec.58
  • libavformat.58
  • libc.6
  • libcairo.2
  • libcairo-gobject.2
  • libdl.2
  • libfontconfig.1
  • libfreetype.6
  • libgdk-3.0
  • libgdk_pixbuf-2.0.0
  • libgdk-x11-2.0.0
  • libgio-2.0.0
  • libGL.1
  • libglib-2.0.0
  • libgmodule-2.0.0
  • libgobject-2.0.0
  • libgstreamer-lite
  • libgthread-2.0.0
  • libgtk-3.0
  • libgtk-x11-2.0.0

openjdk 3:11.0.12+ga (ppc64el/stable)

  • libharfbuzz.0

(Dependency not found)

  • libm.6
  • libpango-1.0.0
  • libpangocairo-1.0.0
  • libpangoft2-1.0.0
  • libpthread.0
  • libX11.6
  • libXtst.6
  • libXxf86vm.1

Issue 432

Library dependency without PKGDEP

11.0.11+1 (loongson3/stable)

Depends: atk, harfbuzz

atk 2.36.0 (loongson3/stable)

  • libatk-1.0.so.0

harfbuzz 2.6.7 (loongson3/stable)

  • libharfbuzz.so.0